SABnzbd 2.x (ReadyNAS OS 6, all platforms)

Yeah, I know. It took me quite a while to release the 2.x series of SABnzbd. Reasons for that are mostly too much work and the changes that needed to be made to get sabyenc into the packages for all platforms. But now, finally here they are:

Have fun!

Comments

  1. Great, thanks ever so much as always.
    Is this a version one needs to purchase again? I don’t see it added to my Account.

    – Rob

    • Jeez, give me second, will you πŸ˜‰ And no, it’s not added to your account for it is (as viewed by my software) a new version.

  2. Edward Niedziejko says:

    I tried to install this, but I keep getting the error message “System: Cannot install application sabnzbd.” and when I try to launch the app, I get a “500 Internal Server Error”.

    I’m running a ReadyNas 104 firmware 6.7.4

    • Edward Niedziejko says:

      Okay, strange. The link in readynas to the app defaults to /apps/sabnzbd/ which doesn’t connect, but using the old shortcut :2708 it works.

    • Edward Niedziejko says:

      The sabyenc module is not installing, that’s what is generating the error message on install. Once loaded, sabnzbd displays the following: WARNING 03/06/2017 12:26 SABYenc module… NOT found! Expecting v3.0.2

      • Can you ssh into your ReadyNAS, run the command “pip install sabyenc” and tell me the output? My RN102 broke so I can’t currently test on that platform.

        • Bryan Booth says:

          Installing collected packages: sabyenc
          [blah blah blah]
          unable to execute ‘arm-linux-gnueabi-gcc’: No such file or directory
          error: command ‘arm-linux-gnueabi-gcc’ failed with exit status 1

          • Bryan Booth says:

            Oh, and sorry, that’s an RN214.

          • Thanks! I guess I know how to fix this but would need access to an ARM based ReadyNAS. I’ll see what I can do in the meantime to prevent the local compilation of sabyenc on the ARM platform. This will result in warning but SABnzbd will still work.

          • Bryan Booth says:

            It actually works, it just gives an error that the install failed and the warning about

            SABYenc module… NOT found! Expecting v3.0.2 – https://sabnzbd.org/sabyenc

            when first run. The test download I ran worked fine. It reports as SABnzbd 2.0.1.

            Thanks very much for an excellent product and your responsiveness to this issue.
            Bryan

          • Bryan Booth says:

            So it DOES appear now that this version of SABnzbd is preventing CouchPotato2_16.09.17-4a0999d-rnx1_all.deb from installing and running. πŸ™ I don’t know how to get any more detailed information. I’ll see if I can get a later version.

          • Bryan Booth says:

            CouchPotato 3.0.1 seems to be working.

  3. gibsonxxi says:

    Will there be a version for legacy OS4 devices?

    TIA.

    Gib.