Apologies for “spamming

As most of you surely have noticed by now the forum software used on my site went nuts and started to send out notifications for new posts to each and every user of the site. I fully understand that this is totally annoying and thus I also have full understanding for the anger this has caused. Let me assure you that this was totally unintentional and that I’m deeply sorry.

What seems to have happened is that after installing an update for the forum plugin the notification settings were reset in such a way that all users got notified about every new post or reply. Unfortunately there was one sole exception: me. I didn’t receive any of these messages, otherwise I’d have stopped this way earlier. The next unfortunate thing that happened was that while users started to complain in the forums, no one did send me an email to inform me about the problem. Since I wasn’t informed about the forum posts about the matter either, again, I didn’t notice anything. That I’m currently on Christmas vacation didn’t help either, otherwise I might have noticed the increased number of site visits and would have started to investigate the reason. Oh well.

So it wasn’t before yesterday when I finally received an email about the problem that I could go about fixing the problem. Until then a lot of mails had already queued up and were on their way. Again, I’m totally sorry for that.

Now the good news is that I believe that the problem is fixed now. I deleted the forum that I think caused most of the problems and I also cleared out all the messages that were still waiting for delivery on my server. I disabled the sending of notification emails and I’m going to check the flags for every user and disable notifications and subscriptions to forum topics there. I have also set up active monitoring of the mail queue size and delivery rate so that I should now get an automatic notification if the site sends out an unusual amount of mails. So in case this happens again (hopefully not) I’ll get informed earlier and can take immediate action. I’m currently watching the mail queues and as far as I can tell everything is back to normal. If things start to look strange again I will completely disable and probably delete the forums.

Lessons learned:

  • Don’t trust plugin updates
  • Monitor more
  • Monitor even more

I wish all of you a Merry X-Mas, hopefully without any further disturbances from my site, a peaceful time and a Happy New Year,

Stefan

 

Python on Sparc Bugfix

First of all I’m really sorry for not being very responsive over the last weeks. Life interfered and didn’t give me much time to respond or even work on bug reports I received. However, having some air to breathe again, I today found the time to work on various problems reported with some of the Python-based add-ons on the ReadyNAS Sparc platform (NV, NV+, Duo).

The problem was not with the add-ons themselves but rather with the Python 2.7.10-sparc-2 add-on. I simply didn’t include an updated SQLite library that was needed by Python. Even more unfortunate was the fact that said library was installed on all of my testing boxes so I wasn’t able to find the problem until I had enough spare time to set up a system from scratch.

Be it as it may, there’s now an updated Python add-on available for ReadyNAS OS 4 Sparc. You can grab it from the “My Account” page.

Again, sorry for the troubles and the inconveniences.

-Stefan

Checkout Problems Fixed

As some of you noticed, there’s been a problem with creating accounts on checkout for first time users. This was due to a problem with one of the plugins on the site. This has been fixed now. Sorry for the inconvenience.